Aceserver problems with Solaris 2.5.1

Mr J. Attwood jattwood at hgmp.mrc.ac.uk
Fri Oct 18 07:21:25 EST 1996


Hi,

	Has anyone got the 4.3 aceserver to work under Solaris 2.5.1? I can
get it to work in standalone mode but have hit major problems when trying

to start it through inetd. There are obvious discrepancies between the
installation instructions and Solaris 2.5.1 (no portmap, for example) so I'm
wondering if the existing code won't run. Our entries in system files are
as follows (not the same server as I'm posting this from):-

/etc/rpc:-
scw9db          20000114        rpc.acedbd

/etc/services:-
scw9db  20000114/tcp    rpc.acedbd

/etc/inetd.conf:-
20000114/1 stream rpc/tcp wait aceserv /usr/local/bin/rpc.acedbd rpc.acedbd /share1/packages/acedb/scw9db 20000114 600:600:0

	It works perfectly in standalone mode but when I run aceclient and
point it at port 20000114 we get a stalled copy of rpc.acedbd which is
immediately replaced when it dies after 10 minutes, so that there is always
a server process in existence. The client eventually reports that it cannot
establish a connection and gives up. Every 10 or 20 minutes syslog reports:-
svc_tp_create: Could not register prog 20000114 vers 1 on tcp
and we have to reboot to get rid of the constantly restarted server process.
We've tried entries in NIS versions of services and rpc, without the slightest
effect, and have run out of ideas.

	Suggestions on what to try, or how to debug the situation, much
appreciated.

Thanks in advance,

John Attwood (j.attwood at hgmp.mrc.ac.uk).




More information about the Acedb mailing list