Problem setting up wbace

F. Coulier coulier at
Tue Jan 11 05:04:33 EST 2000

Hi all,

I am trying to set up AceDB, through webace, for people in my lab.

I am experiencing problems setting up the aceserver through inetd. Hope
someone can help me!

Things that work:
Acedb (4_7I) is running OK locally
Following the help file "running the aceserver", I've made a link to
aceserver (rpc.acedb), 
edited /etc/rpc (added a line "acedb     20000114  "), 
as well as /etc/services (added a line "acedb    20000114/tcp") 
and /etc/inetd.conf ("acedb/1 stream rpc/tcp wait
/usr/local/bin/ rpc.acedbd /home/Database/acedb/ 20000114 1200:1200:0") 

I have restarted inetd (kill -HUP PID# ; I also tried a complete reboot)

I can start aceserver by issuing the command: "aceserver
/home/Database/acedb 20000114", and then the aceclient by typing
"aceclient ip_address -port 20000114 -time_out 60"

Things that don't work:
I cannot start the aceserver by starting the aceclient (without starting
the acesever manualyy).
I get the message:
//! cannot establish connection
//! usage: aceclient host [-port number] [-time_out secs] [-access_info]
[-ace_out] [-ace_in] [-f reportfile parameters]  

I'd appreciate clues on how to resolve these problems. I should add that
I am not used to UNIX (I have been running my Linux box for a few months
only), so the solution might be trivial for a UNIX expert; however,
reading inetd man pages did not help me much.



François Coulier,
"Laboratoire d'Oncologie Moléculaire" et "Atelier de 
Bioinformatique et d'Imagerie",
INSERM Unité 119, 27 bd Leï Roure, 13009 Marseille, France 
Tel: 33 (0) 4 91 75 84 11       Fax: 33 (0) 4 91 26 03 64
mél: coulier at
Site ouaibe:

More information about the Acedb mailing list