performance problems in loading

zgudmunt at zgudmunt at
Tue May 2 09:35:44 EST 2000

   I am now running my Ace-s on a  Linux server with 1 Gb of ram, but
will move them to a dedicated Ace-machine soon, with only 500 Mb of ram.
I was wondering about the cache-sizes and performance issues: should I
use specific cachesizes for the small (few hundred Mb on disk)
local-running Ace-s, accessed through Xace, different from cachesizes
for the server(s) running on the same server?
   The small servers are pretty fast with the default values of
4000/4000, but the big ones (several Gb on disk) can be pretty slow.
Shouldn't I be able to speed the big server and/or xace up significantly
by increasing my caches?


In article <200004252039.QAA17217 at>,
  matthews at (Dave Matthews) wrote:
> jean said:
> : Date: Wed, 19 Apr 2000 13:29:34 +0100 (BST)
> :
> : You fly while you fill the cache
> : but then it should stay fast
> :
> : you describe gioing to 1 record/minute which ius ridiculously slow
> :
> : so i suppose you have defines a cachesize much larger than you
> : memeory and are swapping
> : acedb should not swap
> :
> : please check wspec/cachesize.wrm , the size declared should be a
> : proportion of your real ram
> Xiaowu Gai reported back that the problem was indeed his cache sizes,
> in the opposite direction.  He originally had
> CACHE1 = 4000
> CACHE2 = 4000
> on a machine with 0.5 GB memory.  (I'm not sure if that's RAM or
> The fix:
> > I increased the cache sizes to the same as the ones that you listed
> > 32000] and it solved the problem. I loaded the whole 53,000
sequences in 10
> > minutes. I also tried to increase them a little more and it became
> > faster.
> ---

Sent via
Before you buy.

More information about the Acedb mailing list