AceDB gifaceserver/RPC problem

Ed Griffiths edgrif at sanger.ac.uk
Tue May 23 03:59:52 EST 2000


Steve,


> The first error messages I found on this, from the syslog, were:
> 
> May 15 02:48:07 pgfsun sshd2[9811]: FATAL ERROR: ssh_pty_get_exit_status
> called before the child has exited.
> May 15 03:51:28 pgfsun gifaceserver[10033]: svc_tp_create: Could not
> register prog 200001 vers 1 on tcp
> May 15 03:54:21 pgfsun inetd[133]: config: rstatd/rpc/udp still active
> and was not reconfigured.
> May 15 03:54:21 pgfsun inetd[133]: config: 100083/rpc/tcp still active
> and was not reconfigured.
> May 15 03:54:21 pgfsun inetd[133]: config: acedb/rpc/tcp still active
> and was not reconfigured.
> May 15 04:11:29 pgfsun gifaceserver[10079]: svc_tp_create: Could not
> register prog 200001 vers 1 on udp
> May 15 04:11:29 pgfsun gifaceserver[10079]: svc_tp_create: Could not
> register prog 200001 vers 1 on tcp
> May 15 04:11:29 pgfsun gifaceserver[10079]: svc_tp_create: Could not
> register prog 200001 vers 1 on ticlts
> May 15 04:11:29 pgfsun gifaceserver[10079]: svc_tp_create: Could not
> register prog 200001 vers 1 on ticotsord
> May 15 04:11:29 pgfsun gifaceserver[10079]: svc_tp_create: Could not
> register prog 200001 vers 1 on ticots

The above all suggests to me that there is a problem with your inetd
configuration, it looks to me like 200001 might be in use by another program
(perhaps ssh ?).


> 
> >From the $ACEDB/server.log, I have a lot of entries like
> 
> #### Server starts 2000-05-21_04:25:03
> #### host=(unknown)  port=200001
> ACEDB=/var/local/acedb/compositdb/lettdb
> #### clientTimeout=600 serverTimeout=600 maxKbytes=50
> autoSaveInterval=600
> 
> No more active clients, starting to count-down: 600 s //
> 2000-05-21_04:35:03
> 
> #### Server starts 2000-05-21_04:42:30
> #### host=(unknown)  port=200001
> ACEDB=/var/local/acedb/compositdb/lettdb
> #### clientTimeout=600 serverTimeout=600 maxKbytes=50
> autoSaveInterval=600
> 
> Apparently, gifaceserver starts fine, then tries to register its RPC
> port and fails. Now, the only significant things I did on the system
> before this was install an ssh2 server, but that shouldn't have affected
> any ace stuff or RPC calls. I even disabled the sshd2 daemon
> temporarily, with no effect. Webace was working fine up till this point.
> 

OK, this is possible if you started the server in the foreground from a
terminal, but not if it was inetd started, inetd does all the port registering
_before_ gifaceserver is even started. ssh may have affected the aceserver, what
port is ssh using ??  Also, the port number you have chosen for the aceserver is
in the range known as the ephemeral ports and its possible that ssh may
temporarily have been using this port. This is all speculation and I really need
a bit more information, see below.

> In my /etc/rpc, I have
> 
>  acedb           200001
> 
> (I also tried it with '  rpc.acedbd' appended to this line; no
> difference).
> 
> In inetd.conf, I have
> 
> acedb/1 stream  rpc/tcp wait    d-giface
> /usr/local/bin/rpc.acedbd       rpc.acedbd
> /var/local/acedb/compositdb/lettdb      200001  600:600:50
> 

OK, what is missing here is what you had in /etc/services for gifaceserver and
also what you had in /etc/services and /etc/inetd.conf for the ssh daemon. This
is important because there may be a clash of ports.

Its probably best if you send stuff directly to me from now on and if there is
some basic problem that everyone needs to know about I will post it here.

But for general reference for these types of problems:

1) please include in your note the result of typeing "uname -a" so we know what
machine/level you are running on.

2) please try running the server in the foreground and see if that works, this
is useful info. for us.

3) make sure you include entries from all /etc configuration files:
/etc/servcies, /etc/rpc and /etc/inetd.conf

Please do contact me direct and I'll see what I can do.

cheers Ed

 ------------------------------------------------------------------------------
| Ed Griffiths, Informatics Group,                                             |
|               The Sanger Centre, Wellcome Trust Genome Campus,               |
|               Hinxton, Cambridge CB10 1SA, UK                                |
|                                                                              |
| email: edgrif at sanger.ac.uk      URL: http://www.sanger.ac.uk/Users/edgrif    |
|   Tel: +44-1223-494780 (switch  +44 1223 834244) Fax: +44 1223 494919        |
 ------------------------------------------------------------------------------







More information about the Acedb mailing list