gifaceserver from AceDB_4_8c "dimensions" command.

Ed Griffiths edgrif at sanger.ac.uk
Wed Mar 21 08:55:54 EST 2001


> The gifaceserver "dimensions" command seems to be broken in 4_8c.
> 
> "gif seqget ObjectName; dimensions 720 720; seqdisplay" causes the
> server to lock up and burn cpu time till killed.

OK, I have been pursuing what is probably the same bug with Lincoln for some
time, because we had trouble pinning down some way of causing the problem it was
difficult to debug. The above has been VERY useful.

Actually the problem is nothing to do with the server per se and can be
reproduced with giface, gifaceserver or sgifaceserver for 4_8c. The problem is
to do with dimension setting for virtual graphs. As part of some restructure
work to make the giface "virtual" graph method cleaner, a bug was introduced
into the sizing of default virtual graphs. The bug only shows itself if you set
the dimensions as in the example above. If you don't set them all is fine.

I believe I have fixed this now and I'll be doing some testing over the next few
days.


> "gif seqget ObjectName; seqdisplay" doesn't.

This bothers me, I don't get any problem with a straight display, it maybe that
there are odd cases where the bug from above pathologically causes this case to
fail but I haven't been able to reproduce it.

If you can get a test case that always fails then please let me know.

cheers Ed

 ------------------------------------------------------------------------
| Ed Griffiths, Acedb development, Informatics Group,                    |
|               The Sanger Centre, Wellcome Trust Genome Campus,         |
|               Hinxton, Cambridge CB10 1SA, UK                          |
|                                                                        |
| email: edgrif at sanger.ac.uk  Tel: +44-1223-494780  Fax: +44-1223-494919 |
 ------------------------------------------------------------------------





More information about the Acedb mailing list