ACeDB 4_9f: permissions

Brian Fristensky frist at cc.UManitoba.CA
Thu Feb 28 04:14:06 EST 2002


I just built ACeDB 4_9f on a Solaris 2.8 system,
and I'm having a problem with xace.

So far, the only thing that seems NOT to work
is reading models. Both 'Edit --> Read Models'
and 'Edit --> Read Models and Full Index'
give an error window that says

Sorry, only the administrator owning
the $(ACEDB) directory can modify
the models

However, the wrapper from which I run xace sets
$ACEDB to a directory that I own, and I have
added my userid to wspec/passwd.wrm as the installing
administrator.

I will say that although I own the directories
in which my database is installed (including wspec),
some of the directories (wdoc, wgf, whelp, wquery,
wscripts and wtools) are symbolic links to a central
installation of ACeDB that I don't own, but is world-readable.
The idea is that each lab can have their own
databases, but using one central installation of
most of the ACEDB files, such as scripts, documentation,
binaries etc.

I guess the problem really boils down to: How does
xace determine who owns the $ACEDB directory?

=============================================================================
Brian Fristensky                | 
Department of Plant Science     | Best insult yet from my 5-year old
University of Manitoba          | daughter:
Winnipeg, MB R3T 2N2  CANADA    |  
frist at cc.umanitoba.ca           | "... you, you, you --- TWEETY BRAIN!"
Office phone:   204-474-6085    | 
FAX:            204-474-7528    |    
http://home.cc.umanitoba.ca/~frist/              
=============================================================================





More information about the Acedb mailing list