is the server running? and X problem too

Ed Griffiths edgrif at sanger.ac.uk
Tue Nov 5 05:51:48 EST 2002


Kenji,

> Also, I was testing AcePerl but it seems not to connect to the server.
> When I try to start the server, I've got this message
> 
> [kenji at orodruim WB]$ ./bin/gifaceserver /opt/WB/ 8000
> // Database directory: /opt/WB/
> 
> tar: Member names contain `..'
> 
> The AcePerl program I am testing is this
> 
>            use Ace;
>            # open a remote database connection
>            $db = Ace->connect(-host => 'localhost',
>                               -port => 8000);
> 
>            # open a local database connection
>            $local = Ace->connect(-path=>'/opt/WB/');
> 
>            print $db->status;
> 
>            print Ace->error;
>            print $db->error;
> 
> the error I've got is
> 
>         Can't call method "status" on an undefined value at test.pl
> 
> which I believe is because I am not connecting to the server.

You are using gifaceserver which is no longer supported, the replacment is
sgifaceserver which you can download as part of the server package from the
acedb web site. I suggest you download it and try again.

cheers Ed
-- 
 ------------------------------------------------------------------------
| Ed Griffiths, Acedb development, Informatics Group,                    |
|        Wellcome Trust Sanger Institute, Wellcome Trust Genome Campus,  |
|               Hinxton, Cambridge CB10 1SA, UK                          |
|                                                                        |
| email: edgrif at sanger.ac.uk  Tel: +44-1223-494780  Fax: +44-1223-494919 |
 ------------------------------------------------------------------------





More information about the Acedb mailing list