Table parameters in 4.9f

Dave Matthews matthews at greengenes.cit.cornell.edu
Mon Sep 16 02:42:43 EST 2002


Hi Martin,

I believe you're right, this is a bug in tace/aceserver.  I ran all the tests
I could think of too.  Whatever you do, anything in the [params] position of
the command gets shoved into %1, there's no way to put part in %1 and part in
%2.  The list of commands still says

Table-Maker [-active] [ -h | -a | -p | -j | -x etc.] [-b start] [-c max] [-title]
          [-o out_filename] [-s obj_name] {command_infile | -n name | =} [params]

, params plural, so I suppose the intention is that more than one parameter
is still supported.

- Dave


> To: bionet-software-acedb at net.bio.net
> From: martin.trick at bbsrc.ac.uk (Martin Trick)
> Subject: Table parameters in 4.9f
> Date: Mon, 19 Aug 2002 10:49:15 +0100 (BST)
> 
> Apologies if this is a dumb question, but I can't find an obvious answer
> to it in the documentation. What has happened to the mechanism of table
> parameter substitution between version 4.7l and 4.9f tace?
> 
> Briefly, the following works in 4.7l
> 
> acedb> table -n mytable map1 map2
> 
> so %1 and %2 in the table take the values of map1 and map2
> 
> However, in 4.9f I get
> 
> // Parameter %2 cannot be substituted
> 
> I think the whitespace between map1 and map2 is not being parsed and so
> %1 takes the value of "map1 map2". I've tried lots of combinations of
> escaped quotes but haven't succeeded yet!
> 
> Martin



---





More information about the Acedb mailing list