"%" in tablemaker data

Ed Griffiths edgrif at sanger.ac.uk
Thu Apr 10 02:52:05 EST 2003


Dave,

I see what's happening here, its a glitch introduced a long time ago by the
introduction of the aceIO package which works a little differently from the
freeXXX package which preceded it.

I need to untangle the % stuff in a way that will work, it should be fixed in
the next monthly release, if you need it sooner let me know.

cheers Ed



On Thu, 3 Apr 2003, Dave Matthews wrote:

> Hi Rob,
>
> > Ed fixed a tablemaker bug like this some time ago, so I wonder if it's
> > the same thing.  Could you try it with the latest monthly release (4_9p)?
>
> Yes it's mainly fixed now.  No crash. (Thanks!)
>
> Still a little wart:  Tablemaker outputs "\%" instead of "%".  Example below.:
>
> - Dave
>
> :::::::::::::
> acedb> find colleague test*
>
> // Found 2 objects in this class
> // 2 Active Objects
> acedb> show
>
> Colleague test1
>   Remark      90% here.
>
> Colleague test2
>   Remark      kj022%MTTK at cc.Helsinki.fi
>
> acedb> table percent_crash.def
>
> "test1" "90\% here."
> "test2" "kj022\%MTTK at cc.Helsinki.fi"
>
> ---
>

-- 
 ------------------------------------------------------------------------
| Ed Griffiths, Acedb development, Informatics Group,                    |
|        Wellcome Trust Sanger Institute, Wellcome Trust Genome Campus,  |
|               Hinxton, Cambridge CB10 1SA, UK                          |
|                                                                        |
| email: edgrif at sanger.ac.uk  Tel: +44-1223-494780  Fax: +44-1223-494919 |
 ------------------------------------------------------------------------





More information about the Acedb mailing list