WAIS/gopher indexing peccadillo.

Harry Mangalam mangalam at SALK-SC2.SDSC.EDU
Sun Mar 14 15:52:56 EST 1993


Hi WAISing Gopherheads, 

   I wonder if any veteran Gopher tunnelers might be able to help me.  
I'm trying to set up my first indexing gopher and I can't quite get it.
The documentation is not illuminating, because of the typos and contradictions
(yes I RTFM! and READMEs and INSTALLs and *.docs.).  The problem seems to be 
that the either the indexing part of gopherd can't find the data files or that 
it didn't build correctly in the first place.

   Some details: It's being built on a SGI personal Iris (4D/35),
running IRIX 4.0.5.  The gopherd (from the 1.1 distribution) itself built
fine (as did the wais code - straight 8-b5.1, not Don Gilbert's mods {one
thing at a time!} and both waisindex and waissearch work fine).  I can use
it to look into directories and retrieve files, but it WILL NOT use the
indexer to search the indices built by waisindex. 
   I've even tried it with both gopherd and gindexd (just a link to gopherd, as 
I understand it), both at different ports with pointers to each - still no go.

   My relevant (?) file structure is as follows:

                                usr/
                                local/
                                gopherdata/
   /                               |            \
.Link                           css3000/        .index/
Type=7                          data files      |
Host=+                              .           |
Port=+                              .           |
Path=7/.index/index                             |
Name=Test Gopher                                |
                                                |
                                                |
                                                |
./                 hostdata (below)   index.fn           index.src
../                index.cat          index.hl
.cache             index.dct          index.inv
.zipcruft_0        index.doc          index.query.lock


hostdata (from above)
rangersmith.sdsc.edu
70
/usr/local/gopherdata/css3000

(".zipcruft_0" is a settings file for the SGI ZIP editor.)

   I can get the index query to show up in the gopher window, but when I
type in something that it should find, I get an error box that there are no
files selected by this search and the following debug message from the
gopherd:

0: 0: Mar 14 12:18:02 1993: -1: can't open the delimiters file ./index.dlm, 
using defaults

   If I try to use the original wais "index.src" file as a query (ie,
point the gopherd to /usr/local/gopherdata/.index, the gopherd debug error 
that gets returned is:

Code: S1, The following database is not available: 
/usr/local/gopherdata/.index/index

(All files and directories are read-allowed.)

   So, I'm at a loss to see what's 
going on.  Any help much appreciated.

Thanks,
Harry (If you can't do it right, do it now) Mangalam

Harry Mangalam                                   Vox:(619) 453-4100, x250
Dept of Biocomputing                                   Fax:(619) 552-1546
The Salk Institute                        1'   mangalam at salk-sc2.sdsc.edu
10010 N Torrey Pines Rd                   2'        hjm at salk-sgi.sdsc.edu
La Jolla CA 92037                         3'         mangalam at salk.bitnet






More information about the Bio-soft mailing list