GDE and LINUX

Tim Cutts timc at chiark.chu.cam.ac.uk
Fri May 24 08:39:10 EST 1996


In article <4o3jvm$832 at news.orst.edu>,
Douglas Gordon <gordond at ava.bcc.orst.edu> wrote:
>Hello all.
>
>	I have just installed Linux (Slackware 3.0) and I am looking for some
>help in getting the program GDE set up and running.  I have found the binaries,
>but the program says it is looking is for //libX11.so.3 and never starts up. 
>Has anyone set up GDE on a LINUX machine recently?  I would appreciate any
>help.  Thanks.

First of all, check the version of libX11.so that you have (it probably
lives somewhere like /usr/X11R6/lib ) - you can check all current
libraries by running the program:

ldconfig -v

If it's not on your path, I think it's usually in /sbin/ldconfig

One possibility is that you do not have libX11 version 3.0 at all (and
this above will show that).  That being the case, you should get that
old library from sunsite.unc.edu (in the /pub/linux/X11 tree somewhere
they keep old XFree86 libraries for just this contingency).

The other possibility is that the program has been badly compiled, and
although you have libX11.so.3, it can't find it because it's trying to
find it in the wrong directory.  If that's the casem you have two
alternatives:

1)  If you have the source code, compile the program yourself from
scratch.

2)  If you don't, make a symbolic link where the program is trying to
find the library to the real location of the library.  This is not a
good solution, and should be a last resort.

Hope this helps.

Tim.





More information about the Bio-soft mailing list