help: blast win32 setup

Wayne Parrott wayne at workingobjects.com
Mon Aug 10 13:44:35 EST 1998


Problem resolved. Thanks to Scott McGinnis at NLM for pointing out that
I forgot to locate the ncbi.ini config file in a system directory
(dah!). Thanks Scott.

W

Wayne Parrott wrote:
> 
> Problem: formatting blast db with formatdb.exe
> 
> Situation:
> 1) downloaded and unzipped the Blast win32 executables into dir e:\blast
> 2) created ncbi.ini with contents
>       [NCBI]
>       Data=e:\blast\data
> 3) downloaded the ecoli.aa database from
>    ftp://ncbi.nlm.nih.gov/blast/db/ into dir e:\blast
> 4) ran formatdb as follows
>       >cd e:\blast
>       >formatdb -i ecoli.aa
> 5) formatdb.log has contents
>   ========================[ Aug 10, 1998  1:16 AM
> ]========================
>   Version 2.0.5 [May-5-1998]
>   Started database file "ecoli.aa"
>   FATAL ERROR: [067:001] FindPath failed
>   FATAL ERROR: [067:000] Failure to read sequence. FastaToSeqEntry()
> failed.
> 
>   Formated 0 sequences
> 6) set env NCBI=e:\tmp\blast
> 
> I am assuming formatdb is unable to locate the db file "ecoli.aa". Any
> clues as to what I'm doing incorrectly?
> 
> ---------------------------------------------------------------------
>  Wayne Parrott                   email: wayne at workingobjects.com    |
>  WorkingObjects.com              voice: (972)491-3704
> |
>                                  web: http://www.workingobjects.com |
> ---------------------------------------------------------------------
>  "The main thing, is to keep the main thing, the main thing"
>    lyrics by Scott Krippayne




More information about the Bio-soft mailing list