need buslace card V3/4 for Millennium softwware

hwee2 hwee2 at
Wed Jan 30 05:29:53 EST 2002

we need a oldr version of the Waters/Millipore buslace card (version 3 or 4)
for use with Millennium 2010 software.
Please email me at:  hwee2 at  if you have any for sale.
Thank you.



More information about the Bio-soft mailing list