Jemboss installation help?

Mike Holloway mike_holloway at hotmail.com
Mon Nov 11 08:05:40 EST 2002


Hate looking clueless, but there you go.  I'm trying to install
Jemboss as standalone on a new Redhat 8 installation.  I installed
j2sdk 1.4, and got what appears to be the new Jemboss/Emboss
installation script, and Emboss package.  The script seems to install
things OK, but the runJemboss.csh script doesn't work.  I inserted
into runJemboss.csh the lines given in the Readme:

setenv EMBOSS_INSTALL /usr/local/emboss/
setenv LD_LIBRARY_PATH $EMBOSS_INSTALL/lib

and run it in tcsh shell.  I get:

 Exception in thread "main" java.lang.NoClassDefFoundError:
org.emboss.jemboss.Jemboss
   at 0x4027a15f: java.lang.Throwable.Throwable(java.lang.String)
(/usr/lib/libgcj.so.3)
   at 0x4026d08e: java.lang.Error.Error(java.lang.String)
(/usr/lib/libgcj.so.3)
   at 0x4026eb1a: java.lang.LinkageError.LinkageError(java.lang.String)
(/usr/lib/libgcj.so.3)
   at 0x4026ff76: java.lang.NoClassDefFoundError.NoClassDefFoundError(java.lang.String)
(/usr/lib/libgcj.so.3)
   at 0x402bf0f9: gnu.gcj.runtime.FirstThread.run()
(/usr/lib/libgcj.so.3)
   at 0x40260fdc: _Jv_ThreadRun(java.lang.Thread)
(/usr/lib/libgcj.so.3)
   at 0x4022d78c: _Jv_RunMain(java.lang.Class, byte const, int, byte
const, boolean) (/usr/lib/libgcj.so.3)
   at 0x08048900: ?? (??:0)
   at 0x420158d4: ?? (??:0)
   at 0x080486c1: ?? (??:0)

which makes me think that there's something wrong with the paths for
java in the script, but I can't find anything wrong.  Seems to be
pointing to the right directory.

I've tried a number of things, but not making any headway. Any clues
appreciated.

Thanks,
Mike Holloway
mike_holloway at hotmail.com





More information about the Bio-soft mailing list