Cannot execute cgi script on standalone WWW blast server

Marcus Claesson m.claesson at student.ucc.ie
Fri Feb 13 02:28:54 EST 2004


Hi!

I'm trying to run wwwblast-20031121 on Linux Redhat 8 with Apache 1.3,
but have encountered some problems with the cgi execution.

I have installed wwwblast and set permissions according to
instructions,
but when I click the 'Search...' button in blast.html to start the
search I see these messages in the broswer and the access-log:

Method Not Allowed
The requested method POST is not allowed for the URL /blast/blast.cgi.

==> /var/log/httpd/bioinfo.ucc.ie-access_log <==
143.239.183.39 - - [09/Feb/2004:11:52:29 +0000] "POST /blast/blast.cgi
HTTP/1.1" 405 318

I interpret it as that I have to set ScriptAlias in httpd.conf to the
current directory, so that the cgi scripts will be treated as
applications instead of documents:

ScriptAlias /blast/ "/var/www/bioinfo.ucc.ie/blast/"

Now I can run blast.cgi and get a result, but when I refresh
blast.html
I get 'Internal Server Error' with these messages in the log files:

==> /var/log/httpd/bioinfo.ucc.ie-access_log <==
143.239.183.39 - - [09/Feb/2004:11:46:54 +0000] "GET /blast/blast.html
HTTP/1.1" 500 618

==> /var/log/httpd/bioinfo.ucc.ie-error_log <==
[Mon Feb  9 11:46:54 2004] [error] (13)Permission denied: exec of
/var/www/bioinfo.ucc.ie/blast/blast.html failed
[Mon Feb  9 11:46:54 2004] [error] [client 143.239.183.39] Premature
end
of script headers: /var/www/bioinfo.ucc.ie/blast/bl
ast.html

It seems like ScriptAlias has to be active to run the cgi scripts, but
then the html documents can't be read as the should. Clearly a
conflict
there or am I totally wrong? Are the html documents and cgi scripts
really supposed to reside in the same directory or have I just
misunderstood the configurations?

Extremelly grateful for any help!

Regards,
Marcus
---





More information about the Bio-soft mailing list