[Bio-software] Re: INstalling BLAST on LINUX

Scott Harper Scott.Harper at AdaptiveGenomics.com
Tue Aug 1 10:49:30 EST 2006


On Mon, 31 Jul 2006 19:25:35 +0000, Philipp Pagel wrote:

> orlajosullivan at eircom.net wrote:
>> I am trying to install stand alone BLAST on rehat linux 9.. when I run
[...]
> 
> Well, as the error message said: you are lacking libc-2.3.3. Have you
> checked which version of libc you have installed?

It sounds like you are trying to install a binary (perhaps from a rpm)
that was built using a version of GLIB that does not correspond to the
GLIB version on your system.   You could update your installed GLIB
(carefully so that nothing else ends up broken) or get the ncbi toolkit
source from ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools/ncbi.tar.gz and
build it using the libraries that you already have installed.  The build
is pretty much painless - untar the file (tar xzf ncbi.tar.gz) then follow
the instructions in ncbi/make/readme.unx.

-- 
 . Dr. Scott Harper
 . Adaptive Genomics Corp.
 . 620 N. Main St, Suite 103
 . Blacksburg, VA 24060
 . Scott.Harper at AdaptiveGenomics.com, 540-552-2700



More information about the Bio-soft mailing list