Problems recompiling v5.2 of Linkage on Suns

Mr J. Attwood jattwood at crc.ac.uk
Thu Mar 25 12:24:12 EST 1993


Hi,
	This is partly a caveat for others, partly a plea for help. I've
been trying to install v5.2 of linkage on a Sun SPARCstation 10 model 30
and had serious problems when recompiling with Sun's latest PAscal compiler
v3.0.1. I've so far only tried lodscore, but the supplied executable is
fine, whereas the recompiled version gives a bunch of uncleared numeric
exceptions and answers varying between NaN and 2E20. Recompiling without
the -O optimisation flag gives the same answers as the supplied
executable.
	I've contacted Sun, who aren't aware of any relevant bugs, but
agree there seems to be a problem. I've just heard that recompiling with
v2.1 of their pc gives different wrong answers when the code is optimised.
They are saying that they can't do much unless the problem can be localised
to just a part of the 8000 odd lines of Pascal code.
	Has anyone else had similar problems, and/or got any further with
finding what's going wrong? I'm no mathematician but, since the program
usually comes up with -infinity for the likelihood on its first iteration,
it seems to me that this is tantamount to saying that the input data is
impossible, which might give a clue to where the problem is. I'm trying to
insert code to dump the input data back out to a file, in case it's being
read or interpreted wrongly, but beyond this I'm out of my depth.

John Attwood,
MRC Human Biochemical Genetics Unit,
London, UK
j.attwood at mrc-hbgu.ucl.ac.uk



More information about the Gen-link mailing list