Problems recompiling v5.2 of Linkage on Suns

Mats Sundvall sundvall at perrier.embnet.se
Wed Mar 31 03:01:29 EST 1993


In article 1410 at gserv1.dl.ac.uk, jattwood at crc.ac.uk (Mr J. Attwood) writes:
>Hi,
>	This is partly a caveat for others, partly a plea for help. I've
>been trying to install v5.2 of linkage on a Sun SPARCstation 10 model 30
>and had serious problems when recompiling with Sun's latest PAscal compiler
>v3.0.1. I've so far only tried lodscore, but the supplied executable is
>fine, whereas the recompiled version gives a bunch of uncleared numeric
>exceptions and answers varying between NaN and 2E20. Recompiling without
>the -O optimisation flag gives the same answers as the supplied
>executable.
>	I've contacted Sun, who aren't aware of any relevant bugs, but
>agree there seems to be a problem. I've just heard that recompiling with
>v2.1 of their pc gives different wrong answers when the code is optimised.
>They are saying that they can't do much unless the problem can be localised
>to just a part of the 8000 odd lines of Pascal code.
>	Has anyone else had similar problems, and/or got any further with

I had exactly the same problem here in Uppsala. I haven't had time to bug Sun
with it but I wouldn't accept their view that they can't do anything if you
cannot give them just five lines of code that give the same problem.

I'll call them today and I'll send them the whole program. It's their job
to trace down compiler bugs.

Regards,

Mats Sundvall
Dept Med Genetics
Uppsala University
Sweden



More information about the Gen-link mailing list