Mac OSX - emboss integration

David F. Spencer dspencer at is.dal.ca
Thu Jun 26 03:14:37 EST 2003


In article <f634af6e.0306171952.22c555fe at posting.google.com>,
mlds at unimelb.edu.au (MDS) wrote:

> As with the previous post, I am having difficulty getting emboss to
> integrate with the staden package. I also have a problem with abiview,
> which doesn't show a graphic, just crazy text. Staden package works
> (except for abiview) and emboss works from the command line, but
> emboss doesn't work from the staden interface.

In the Staden binaries subdirectory (folder) there is a script called
'create_emboss_files'. Run this and a new menu item 'Emboss' appears in
'spin'. I haven't studied the script but I assume that the EMBOSS programs
have to be on the system path to be found. I use a traditional file setup
with the Staden installation (i.e. the Staden subdirectory) in
'/usr/local/bin' and the emboss program files also in '/usr/local/bin'.
Not all of the EMBOSS programs are linked into the 'spin' menu; this is
explained in the html documentation that comes with the Staden package.

As for the EMBOSS program 'abiview' you must have the environment variable
"PLPLOT_LIB" set to point to the location of the font(s) that are
installed with EMBOSS. In my system "PLPLOT_LIB" is set to
'/usr/local/share/EMBOSS'. However this may not solve your problem. I
built EMBOSS from source but 'abiview' isn't working, it quits after the
option 'Graph type[x11]' is selected, giving the error message "Error in
XCreatePixmap: BadDrawable (invalid Pixmap or Window parameter)". I
haven't attempted to track down the problem. 'Trev' in Staden is far
better for viewing automatic sequencer chromatograms.

Dave




More information about the Staden mailing list