[Staden] Re: using emboss programs from spin

Guy Bottu via staden%40net.bio.net (by gbottu from ben.vub.ac.be)
Sun Oct 29 06:33:18 EST 2006


Miguel Ortiz Lombardia <mortiz from cnio.es> wrote:

> But then I get many "qualifier" errors. I think this is because the
> spin_emboss package instead of the spin2_emboss one is being used. I
> checked at least that for the EMBOSS program "matcher".

> Could someone tell me how to enforce the use of spin2_emboss?

I think the nature of your problem is different. create_emboss_files 
contains a line
exec stash  $STADLIB/spin2_emboss/create_emboss_files......
that tells the program to make files for spin2 ; you can replace this by
spin. spin2 is a successor program of spin, which however did not get
beyond alpha test because the cut of the support for the Staden team.
There is more serious : spin worked relatively well with EMBOSS 2.8 but
starting with EMBOSS 2.9 the syntax of the ACD files was changed and
since then under spin EMBOSS programs do not greyout optional parameters
as needed or simply do not run at all. I managed to make it work at the
BEN site, but only with a lot of ugly hacking....
Peter Rice from the EMBOSS team had promised to do some work on Staden
to make it again EMBOSS compatible, but he has a lot of other things to
do and I am afraid he did not yet come to it. Maybe you can send a mail
to the EMBOSS mailing list emboss from emboss.open-bio.org

	Regards,
	Guy Bottu,
	Belgian EMBnet Node



More information about the Staden mailing list