No speedup using multiple processors on 10-processor PowerChallenge

Kay Diederichs kay at loop2.biologie.uni-konstanz.de
Wed Nov 15 10:15:10 EST 1995


Dear X-PLOR users,

for a couple of weeks, I have access to a SGI PowerChallenge (10 R8000
processors, 1Gb memory, running IRIX 6.0.1). I compiled and linked X-PLOR 3.1f
after downloading the relevant files from xplor.csb.yale.edu.
Using the benchmark1 and benchmark2 scripts, I came up with the following,
surprising results:

          MP_SET_NUMTHREADS     CPU time        wall-clock-time
benchmark1  1                 76.1 seconds          95 seconds
            2                 55.8                 286
            3                 45.7                 743
            4                 44.4                 861

benchmark2  1                 20.4                  27
            2                 19.2                 306
            3                 18.1                 280
            4                 17.6                 277

I should add that the system load was between 30 and 50 during the tests, but
the results seem pretty reproducible.
Does this mean a $$$$ computer does not complete a single job in less time
than, say, a 250MHz R4400 Indigo2 workstation? Can I do anything about it? 
---
Kay Diederichs                    
email: kay at loop2.biologie.uni-konstanz.de     Tel: +49 7531 88 4049  Fax: 3183
Fakultaet fuer Biologie, Universitaet Konstanz 
Postfach 5560 (M656), D-78434 Konstanz, Germany




More information about the X-plor mailing list