[X-plor] problem with CNS

Yi Xue yi-xue at northwestern.edu
Mon Aug 7 20:30:06 EST 2006


Dear all:
    I am using CNS to do MAD experimental phasing.
    I did data prep., heavy atom search. However, when I tried heavy metal
refinement( mad_phase.inp), the program terminated with following error
msgs:




 XRAY>
 XRAY>   {- declare zero array -}
 XRAY>   declare name=null domain=reciprocal type=real end
 XDECLARE: Object NULL has been declared.
 XRAY>   do (null=0) ( all )
 XSFAL: allocating space for real reciprocal space object.
 Total of     82613 structure factor elements were selected.
 XRAY>
 XRAY>   if ( $log_level = verbose ) then
 NEXTCD: condition evaluated as false
 XRAY>     set message=normal echo=on end
 XRAY>   else
 XRAY>     set message=off echo=off end

 %DO-ERR: unrecognized statement or variable/type mismatch:
    do (mad=amplitude( ))
                       ^
 %XDOTYPE-ERR: Variable/type mismatch:
    do (mad=amplitude( ))
                        ^
 %XDOTYPE-ERR: Variable/type mismatch:
    evaluate
    ^^^^^^^^
 %DO-ERR: Expression incomplete:
    evaluate
    ^^^^^^^^
 %SHOW error encountered: There were errors in DO expression.
   (CNS is in mode: SET ABORT=NORMal END)
 *****************************************************
 ABORT mode will terminate program execution.
 *****************************************************
 Program will stop immediately.


    What happened? and, what should I do?


thanks a lot
Yi




More information about the X-plor mailing list